Support Availability Notice

Incident Report for PagePixels Screenshots

Resolved

This incident has been resolved.
Posted Aug 19, 2026 - 19:48 UTC

Monitoring

The PagePixels team is based on the Big Island of Hawaii, which was hit by Hurricane Lala. While our screenshot automation service will remain fully operational (as it runs on infrastructure outside the affected area), our ability to respond to support requests will be delayed.

We’ll continue to monitor the situation and post updates here as needed. Thanks for your understanding.
Posted Aug 17, 2026 - 22:57 UTC